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INTRODUCTION

Congratulations on your purchase of the Video Capture add-on card.
This capture card comes complete with the VideoCapture utility for
capturing still images and full-motion video to create great
multimedia presentations. This capture card can also serve as a
compatible video source for a wide variety of applications including
video-conferencing software for cyber-conferencing over the Internet!

Key Feature

• Live video display in a full screen (640x480) or in a window.

• Video input sources: 1 mini-DIN, 1 composite video and 1 S-video
input.

• Video systems supported: NTSC, PAL and SECAM.

• Full motion video and still image capture.

• Video display adjustable with brightness, Contrast, Saturation, and
Hue controls.

• Design is based on 32-bit PCI local bus (supports PCI bus-
master, video data through PCI to VGA display memory).

• No VGA feature connector required for compatibility with virtually
all VGA controller cards and systems with on-board video.

• No video frame buffer required for the best cost performance
ratio.

• Plug & Play supported for easy installation and setup.

• Software support for Windows 95/98:

∗ VideoCapture utility: video source select, video display
adjustments (brightness, contrast, saturation, and hue), still
image capture, full motion video/audio capture.
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System Requirements

• 32-bit PCI Local Bus system (with PnP)

• CPU 486DX 33Mhz or higher, Pentium CPU recommended

• 8MB System RAM or more, 16MB memory and 1GB hard disk
recommended for motion video capture

• Windows 95/98

• VGA display in 32K, 64K or 16.7M color mode with hardware
assisted video playback acceleration and DirectDraw support

• Sound card and speakers required for audio support

Content Checklist

The package consists of

§ Video Capture Card

§ “Tekram Multimedia Drivers & Utilities” CD-ROM

Make sure all of the above components are accounted for before you
begin the installation.
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HARDWARE INSTALLATION

Installing the Capture Card

Important: Handle circuit boards by the edges or bracket. Touch the
bare metal of your computer case before handling any circuit boards
to prevent static discharge damage.

1. Turn OFF all power to your system, including any peripherals
(printer, external drives, modem, etc.).

2. Disconnect the power cord and the monitor cable from the back of
the computer.

3. Remove the computer cover. Refer to your system user’s manual
for instructions.

4. Align the gold-fingered edge on your card with an empty PCI
expansion slot and gently insert it into place. You may need to
remove the cover from the rear of the PCI expansion slot that you
selected.

5. Replace the screws to secure the card retaining bracket in place.
6. Replace the computer cover.
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External Connectors

Connect your external video sources to the connectors of the capture
card as shown below.
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SOFTWARE INSTALLATION

Installing the Windows 95 Device Drivers

After the capture card is properly installed in the system, Windows 95
will automatically detect the card as a Multimedia Device upon boot-
up, and display a “New Hardware Found” screen like the one shown
below. Click on “Driver Disk from Manufacturer”, insert the “Tekram
Multimedia Drivers & Utilities” CD-ROM into your CD-ROM drive and
follow the on-screen instructions to install the drivers for the capture
card.

Type in D:\C205 for the driver location.

After the required files are copied, the system will ask if you wish to
restart your computer. Select YES to restart.

Note: The Windows 95 setup screen on your system may look
different than the one shown above if you have OSR2 /
Windows 95 (B) installed.
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Installing the Windows 98 Device Drivers

1. After the capture card is properly installed in the system, power on
your system. Windows 98 will automatically detect the card as a
PCI Multimedia Video Device upon boot-up, and display a “New
Hardware Found” screen, then “Add New Hardware Wizard” dialog
box will appear like the one shown below.

2. Then select “Search for the best drive for your device.
(Recommended).”

3. Next select “Specify a location” then type in D:\C205

4. Follow the on-screen instructions to complete the driver installation.
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The Autorun Screen

After rebooting, insert the “Tekram Multimedia Utilities & Drivers”
CD-ROM into the CD-ROM drive. The Autorun screen will show up. If
it does not appear, run D:\AUTORUN (where D: is your CD-ROM
drive).

Double-clicking the appropriate product model name C205 brings up
the “Function Selector” submenu.
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Installing the VideoCapture utility

1. Select Install Application on the Autorun Screen. The following
dialog box appears:

2. In the Installation Directory, type the drive and directory where you
want the software installed. The default path is C:\TEKCAP.

3. Click Continue to start copying of the files.

4. Click on the Exit button after the
installation is complete. The
“VideoCapture” program group is
added to your Windows desktop,
containing the application icons
as shown:

Use the Uninstall program when you
want to remove this application
program.
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VideoCapture UTILITIY

This application is used for capturing still images and full-motion
video plus audio from any video device that features either a mini-
DIN, an S-Video-Out or a Composite Video-Out (RCA) connector.

The VideoCapture utility saves the captured still image as DIB file
format. The video is saved as AVI file format.

Application Window

Double-click the VideoCapture icon from the “VideoCapture” program
group to start the program. The application window appears:

• Title and Information Bar: Contains the program name, the
standard Windows Minimize, Maximize and Exit buttons. Also
displays information about actions taking place in the window.

• Menu Bar: Lists the five menus of the program.
• Display Area: The “screen” where your media plays.

To exit from the program, either click the Exit button on the Title Bar
or choose Exit from the File menu.



VideoCapture UTILITY

13

Selecting the Video Source and Adjusting the Picture
Properties

From the Options menu, choose Video Source. The Video Source
dialog box appears:

• Video Connector: Select video input source (Mini DIN,
Composite or S-video).

• Video Standard: Select video system type for the current input
source. For proper operation, you must make sure that the Video
System is correctly set for any given Video Source. For instance,
your CCD camera may be a PAL device, whereas a camcorder or
VCR may be a NTSC device.

∗ Changing the video system type brings up the Video Format
dialog box. For Video Format settings, please refer to later
section.

• Color: Drag the slide bars to adjust the brightness, contrast,
saturation and hue of the displayed video.



VideoCapture UITILITY

14

Selecting Overlay / Preview Mode

Select Overlay or Preview mode from the Options menu. In Overlay
mode, video is transferred directly from the capture card to the
memory of the display card without using any CPU resources. This
results in better on-screen viewing. However, the capturing operation
automatically uses the Preview mode, therefore, the quality of the
captured image or video is the same regardless of the setting.

The Overlay mode is dependent on DCI - Display Control Interface -
driver support from your display card manufacturer. Select the
Overlay mode if it is supported.

Setting the Video Display Size and Format

From the Options menu, choose Video Format. The Video Format
dialog box appears:
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• Image Dimension: Selects the image display size. Options are
160 x 120 pixels (1/4), 320 x 240 pixels (1/2), and  640 x 480
pixels (Full).

• Image Format: Select the image type and the amount of colors it
will contain.

Note: The higher the number of colors and the bigger the window
size, the larger the size of the AVI file. It is recommended that you
keep the image size at the default and colors not higher than 16 bits.

Creating New Palette

If the image type of the displayed video is 256 colors (8-bit color) or
less, setting a new color palette may improve the picture
dramatically.

From the Options menu, choose Make Palette to create a new
palette. The following dialog box appears:

Colors: Specify the number of colors to be contained in the palette.

Frame: Specify how many frames from which the color is to be
selected for the palette.
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Changing the Settings for Video Capture

Choose Capture Settings from the Capture menu to change the
preferences for video capturing. The dialog box appears:

 

* All the values will return to default after exiting the program.

• Frame Rate: Number of still video frames that can be captured
and converted to digital format in one second. A lower frame rate
will produce less fluid motion, but will result in a smaller AVI file.

• Enable Capture Time Limit: Check this box to specify the
maximum recording time.

• Capture Audio: Check this box to capture audio with the video.

• Video Buffers: If the memory capacity allowed, more buffers will
result in higher video transfer rate. It is recommended that you
leave it at the default value.

• Key to Abort Capture: Select the key to be used for ending video
capture.
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• Mouse to Abort Capture: Select the mouse button to be used for
ending video capture.

• Hit OK to Capture: By default
the capturing begin as soon as
you choose the capture
command from the Capture
menu. Click this check box to
have a dialog box appear
before the capturing start for
re-confirmation.

• Use DOS Memory: With this option enabled, the program will try
to use the DOS memory for faster performance. However, the
memory capacity is limited to under 1 Megabyte.

Selecting the Audio Format

With the Capture Audio option enabled (See the previous section),
the Audio Format command from the Options menu allows you to
specify the format of sound you will record with your video. The
following dialog box will appear:
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Enhancements like Stereo Sound will result in less bandwidth being
used for Video Recording. Therefore, unless sound is important, keep
the settings low or capture only the video.

You can also save a specific audio format with a name you specified,
which is then added to the list. Remove it with the Remove button
when you no longer need it.

Displaying Close Captioned Text

If you are playing an NTSC videotape containing closed captioned
material, you can enable the close captioned text to be displayed with
the video. Choose Video Display from the Options menu. The
following dialog box appears:

Enable CC: Check this box to display the close captioned text. The
text overlays the video as in standard TV. Select Channel 1 or
Channel 2 for the source of the close captioned text.

File Name: Specify the text file name for the transcribed closed
captioned text.

Alert Token: Type in this field the word that the program will detect
for transcribing automatically.
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Selecting the Video Compressor

From the Options menu, choose Compression to select the video
compression algorithm. The dialog box appears:

• Compressor: Selects the compressor to be used.

• Compression Quality: Sets the compression rate. The higher
number will result in less distortion but bigger AVI file.

• Key Frame: The bigger the interval between the key frames, the
more the distortion will be.

• Configure: Configures the settings for the selected compressor.

Allocating Memory Space

Digital video takes up a large amount of hard disk space. Before you
start to capture a movie, check out the available hard disk space and
set aside a memory size for the captured file by selecting the
Allocate File Space from the File menu.
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Specifying the File Name for Video Capture

Before capturing a motion video, you should first decide the name of
the captured file and the location on the hard drive that the image will
be stored in, or the file will be saved to the default name and path
c:\capture.avi

Choose Set Capture File from the File menu. The following dialog
box appears:
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Capturing Motion Video

Click Capture Video under the Capture menu to initiate video
capture. After the movie is saved to disk, you will be shown the
amount and percentage of dropped frames. After the capturing is
complete, the video display will remain still. Click Preview or Overlay
from the Options menu to continue the playing.

Capturing a Still Image

Click Capture Frame from the Capture menu. This captures image to
the hard disk with the default path and filename: c:\tekcap.dib.

Copying to the Clipboard

To copy the displayed image onto the Clipboard, choose Copy from
the Edit menu. The image is captured as a bitmap and can be pasted
to any application supporting the Windows software Clipboard
function.


